Pegasus Mail & Mercury

Welcome to the Community for Pegasus Mail and
The Mercury Mail Transport System, the Internet's longest-serving PC e-mail system!
Welcome to Pegasus Mail & Mercury Sign in | Join | Help
in
Home Blogs Forums Downloads Pegasus Mail Overview Mercury Overview Wiki

Pegasus not placing return address in "To" field

Last post 08-08-2018, 0:03 by drfishercalgary. 6 replies.
Sort Posts: Previous Next
  •  07-06-2018, 9:05

    Pegasus not placing return address in "To" field

    Hello to all . . . .

     Just wondering if anyone else has experienced Pegasus failing to place a return address in the "To" field when replying to an email ??

     I've done some testing and discovered that this is happening only on one specific email address which I have confirmed to be a legit and correctly formatted address.

     I've never run into this before and in one of my tests I have substituted a different address in the original message which is properly placed in the "To" field when I hit the reply button.  This would of course suggest the the original email address is somehow incorrect,  but it is not,  if I type the address in myself the reply gets sent with no problem.

     Any ideas ???   Thanks,  

  •  07-07-2018, 4:28

    • Jim Adney is not online. Last active: 11-14-2018, 3:37 Jim Adney
    • Top 500 Contributor
    • Joined on 09-27-2012
    • Madison, Wisconsin, USA
    • Member
    • Points 435

    Re: Pegasus not placing return address in "To" field

    Is it possible that this particular addressee has a Reply To: line in his header? If so, Pegasus uses this address instead of the To: address.

    -
    Jim Adney
    Madison, WI USA
    Pegasus user since 1995
  •  07-07-2018, 7:34

    Re: Pegasus not placing return address in "To" field

    Hi Jim, thanks for the response.  There is no Reply To line in the message header, just double checked to make sure.

     It's really weird . . . I have substituted a few other email addresses in the header and each one will enter the substitute address in a reply,  but his address just leaves the field  blank. His address is accurate as shown in the header, I can copy and paste it into the blank field and it works fine.    I am really really curious what is causing this !!!

    - Dave 

  •  07-09-2018, 16:52

    • Greenman is not online. Last active: 19 Nov 2018, 16:31 Greenman
    • Top 10 Contributor
    • Joined on 07-19-2007
    • UK
    • SuperStar
    • Points 13,650

    Re: Pegasus not placing return address in "To" field

    When you click the reply button are you presented with the reply options? You can select the addresses you wish to reply to, but my settings show none of the addresses are selected, and the option 'Recipients selected using the controls below' is checked, yet the sender's address still populates the To: field of the reply itself.
  •  07-12-2018, 0:35

    Re: Pegasus not placing return address in "To" field

    Thanks for the input so far . . . .  here is an update that makes this problem even more interesting.

     With the idea that a Pegasus file might have been corrupted I reinstalled the latest version of the program and it appeared that the problem was solved . . . . I did a couple of test replies to my friend and Pegasus was putting his addy into the  "To" field.

     So, just before coming in here so say the problem was solved I fired up Pegasus again just to make sure and it was no longer working properly, it would not place this particular addy into the "To" field.

     This is really weird.  Does anyone know exactly what line in the Raw header that Pegasus looks for to place an addy in the "To" field ??

     Thanks,

    - Dave 

  •  07-12-2018, 2:21

    • Brian Fluet is not online. Last active: 11-16-2018, 15:39 Brian Fluet
    • Top 10 Contributor
    • Joined on 12-24-2014
    • North Carolina, USA
    • SuperStar
    • Points 22,430

    Re: Pegasus not placing return address in "To" field

    drfishercalgary:
    This is really weird.  Does anyone know exactly what line in the Raw header that Pegasus looks for to place an addy in the "To" field ??

    That can be controlled by the Reply options but if no recipients are selected in the Reply options dialog then I believe it uses the Reply-to header if one exists otherwise the From header.

    That said, there is a quick reply option that defaults to using the last options.  I don't know what the behavior is when the last options used specified a header that doesn't exist in the current message.

  •  08-08-2018, 0:03

    Re: Pegasus not placing return address in "To" field

    UPDATE -  thought I would close out this post with a very surprising remedy to the problem.   The reason for the strange behavior with just one email address is still unknown but the remedy came through deleting all of the 4 profiles I had in the program and rebuilding them from scratch.  Much to my surprise the problem went away and subsequent testing of that one particular email address has produced no further problems.   Thanks to all who offered suggestions.

     

    - Dave 

View as RSS news feed in XML

Contact | Advertise | Host provider: PraktIT | Terms of Use | Privacy Statement
Copyright © 2007-2011 David Harris / Peter Strömblad. | Pegasus Mail Home Page